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SfM/MVS による航空写真の広域オルソモザイク画像の作成手順 

 

中辻 享（甲南大学文学部） 

渡辺一生（京都大学東南アジア地域研究研究所） 

 

１．はじめに 

 航空写真が 1930 年代に全世界で本格的に撮影され始めてから 90 年になる。これら画像

の多くは各国の地図製作機関で長年保管されており、鮮明で解像度も高いことから資料価

値は非常に高い。しかし、後に述べるように、そのほとんどは利用される機会が少ない。衛

星画像が撮影され始めたのは 1972 年であり、2000 年ごろまでその解像度は航空写真と比

べればずっと低かったことを考えると、航空写真は 20 世紀の土地利用・土地被覆の変化を

高解像度でたどることができる唯一の画像データということができる。 

 航空写真の活用が進んでいない要因には、以下の 3 つがあげられよう。まず、多くの国で

航空写真を活用するシステム自体が整っていない。これは、本稿が対象とするラオスのよう

な発展途上国について特にいえることである。ラオスの場合、1982 年頃と 1998 年頃に全

国を対象に撮影された航空写真のフィルムが、同国の国立地図局（National Geographic 

Department）に所蔵されており、2000 年代の初頭にはいずれも紙焼きで販売されていた。

しかし、現在は焼き付け機の故障のため紙焼きでの販売はされていない。1998 年の航空写

真に関しては、その後フィルムのスキャンがなされ、その画像データが販売されている。と

はいえ、スキャニングの質があまりよくない。また、1982 年の航空写真にいたっては、12

インチ四方という特殊なサイズ1)であることから、いまだスキャンさえなされていない。画

像データとしてコンピューターで利用するためには、紙焼きよりも高解像度でフィルムを

スキャンするほうが画像拡大時に地物がとらえやすい。また、保存の観点からいっても、で

きるだけ早く高品質のスキャンをしておくべきである。しかし、航空写真専用のスキャナー

は高価なため入手しにくく、事実上フィルムは放置された状態になっている。 

 以上はラオスでの現状であるが、発展途上国では大なり小なり当てはまるのではないか

と推察される2)。 

一 方 、 ア メ リ カ 合 衆 国 国 立 公 文 書 記 録 管 理 局 （ National Archives and Records 

Administration: NARA）には、全世界の古い航空写真が保管されており、ラオスに関しては

 

1) 後述するように、航空写真のサイズは 9 インチ四方が標準であり、1998 年に日本

（JICA）が撮影した航空写真はこのサイズであるため、スキャンが可能であった（現在は

それに用いたスキャナー自体も故障している）。一方、1982 年の航空写真はソビエト連邦

が撮影したものである。 

2) また、国防上の観点から航空写真を一般に公開することを拒否する国も多いと思われ

る。 
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1940 年代～60 年代の航空写真がここで入手可能である3)。これらを使うことで 80 年前に

さかのぼる土地利用・土地被覆を明らかにすることができる。 

 航空写真の研究上での利用を阻んできた第 2 の要因として、そのオルソ幾何補正の作業

が煩雑で時間を要する点が挙げられる。オルソ幾何補正とは、写真を地図と同様の正射投影

画像に変換し座標系に位置付ける作業の事をいう。航空写真を地理座標系に位置付け GIS

上で利用できるようにし、例えば過去の集落の位置や耕作地の面積を把握するためには、オ

ルソ幾何補正が必須となってくる。特に山間地においては、過去の航空写真に写っている地

物が現在の地図や幾何補正された衛星画像（Google Satellite など）のどこに位置するのか

を特定するのは地理的な絶対位置が無いと難しい。そういった点においてもオルソ幾何補

正は非常に重要である。しかし、従来の航空写真のオルソ幾何補正の一連の作業はいずれも

手間暇のかかるものであった4)。そのため、広域にわたる数十枚以上の航空写真のオルソ幾

何補正をしようとすると人海戦術的な方法に頼らなければならず、コストパフォーマンス

的にも成立するものではなかった。 

 航空写真の利用を阻んできた第 3 の要因としては、目視判読の作業にやはり手間と時間

がかかることがある。ここでいう目視判読とは、オルソ幾何補正済みの写真から土地利用・

土地被覆を目視で判読し、その境界を作成する作業である。よって、東南アジアを対象とし

た過去の航空写真から土地利用・土地被覆を復元しようとする研究は、そのほとんどが 1 村

落～数村落を対象とするレベルにとどまっていた5)。 

 本稿は上にあげた要因のうち、特に第 2 の要因について課題を克服しようとするもので

ある。多数の航空写真をオルソ幾何補正し 1 つの画像としてつなぎ合わせる（モザイクす

る ） 手 法 と し て 、 本 稿 で は SfM/MVS 多 視 点 ス テ レ オ 写 真 測 量 （ Structure-from-

Motion/Multi-View Stereo Photogrammetry）を採用する。これは、「多数の視点を持つ複数

の写真画像から、それぞれの写真の撮影位置と対象物の 3 次元形状とを自動的に復元し、

さらに対象物の詳細な 3 次元形状モデルを生成（早川ほか 2016）」しようとする技術であ

る。おもに UAV(Unmanned Aerial Vehicle)や手持ちデジタルカメラを用いた地形や地物の

3 次元モデルの生成に利用されているが、航空写真から撮影対象の 3 次元モデルを生成し 2

次元のオルソモザイク画像を作成することも可能である（内山ほか 2014）。本稿では、この

技術を用いて、できるだけ早く簡便に精度の高いオルソモザイク画像を作成する方法を報

告する。なお、SfM/MVS を実行するソフトウェアにはフリーのものと商用のものがあるが、

今回は商用ソフトウェアである Agisoft Metashape Professional Version 2.0.1 を使用した。

 

3) NARA の航空写真閲覧の手順については、佐藤廉也ほか（2018）を参照されたい。 

4) 例えば、小林（2013）は DEM を用いて、一枚ずつ航空写真のオルソ幾何補正をしてい

く手法を紹介している。一枚の航空写真に対して 20 点のコントロールポイントを与える

必要があり、その作業に時間を要する。そのため、大面積のオルソ幾何補正には向いてい

ない。 

5) 例えば、Nakatsuji(2019)や渡辺ほか（2007）とそこに挙げられた参考文献を参照。 
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また事例として、ラオス北部のボケオ県南部からルアンナムター県南部にまたがる地域を

1945 年 2 月 19 日に撮影した 16 枚の航空写真を用いることにする6)。これらの写真のオー

バーラップ部分の実面積（出来上がりのオルソモザイク画像の実面積でもある）は約 500km2

であり、撮影縮尺は 1:44,000 である。これらの写真は上述した NARA に保管されているも

のである。スキャン解像度は、1200dpi とした7)。 

 以下では、第 2 章でカメラ情報や DEM といった SfM/MVS の実施のために必要なデー

タを事前に入手し、それを Metashape で読み込み可能な形に整える方法について説明する。

次に、第 3 章では写真画像自体を SfM/MVS の実施に適するように加工する方法を説明す

る。具体的には、写真の色調を全画像で統一させつつ、その見やすさを向上させる作業、不

必要な枠の部分などにマスクを施したりする作業について説明する。これらは SfM/MVS 処

理を実施するための事前作業であるが、続く第 4 章においては、Metashape を用いて本格

的に行う処理についての一連の作業について説明する。具体的には、アラインメント、コン

トロールポイントの入力、ポイントクラウドの生成、DEM の作成、オルソモザイク画像の

作成などになる。 

 

２．SfM/MVS に必要な関連情報の入手 

（１）カメラおよび撮影条件についての情報の入手 

 対象とする航空写真の標定図やフィルムの画像周辺部の記載、画像への書き込みなどの

情報から、カメラの焦点距離、各写真撮影時のカメラの座標値・高度・撮影時刻などの情報

を取得する。今回対象とする 12 枚の写真は、標定図とフィルム画像部の直接の書き込みか

ら、1945 年 2 月 19 日の 11 時 24 分～12 時 15 分8)の間に撮影された 24CMS-5M-5 Roll-1

というフィルムの一部であることが判明した。カメラの焦点距離は 151.6mm、飛行高度は

22,000 フィート（6705.6 メートル）であった。 

 

（２）カメラの撮影座標値の取得 

 今回のように、古い航空写真に関しては、それぞれの写真撮影時のカメラの地理座標は分

 

6) 航空写真の出典は次の通り。Aerial Photograph, Can #ON057359, 24CMS-5M-5 Roll-1 

V:20-V:35; “Aerial Photograph of Indochina (Laos), 19/02/1945”; Records of the Defense 

Intelligence Agency, Record Group 373; National Archives at College Park, College Park, 

MD. 

7) 筆者はすでにラオスの 1959 年、1982 年の航空写真に関しても SfM/MVS によるオルソ

モザイク画像作成に成功しており、今回はより古い年代の写真に関しても同じ方法が適用

できるかどうかを試みた。 

8) 撮影フィルムの 1 枚目の撮影が 11 時 24 分であり、89 枚目に 12 時 15 分と記載されて

いた。34 秒ごとに 1 枚撮影されていた。なお、この時刻は GMT ではない。標定図には撮

影対象国が Indochina (Laos)と記載されていることから、ラオスの現地時間とみてよい。 
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からない。そこで、ここでは撮影された写真の主点（中心点）の地理座標（ただし平面座標

のみで標高は除く）をカメラの撮影座標に近似するものと考え、それを GIS 上に位置付け

られた Google Satellite から取得することにする。ArcGIS Pro で新しいプロジェクトを作成

し、Map 上に Google Satellite を表示する。Google Satellite を Arc Map に表示する方法は

下記を参照。 

 

Add Google Maps to ArcMap and Pro（2023 年 11 月 12 日閲覧） 

https://socalgis.org/2020/12/02/add-google-maps-to-arcmap-and-

pro/#:~:text=Once%20logged%20in%2C%20open%20a,box%20%E2%80%9CUse%20as

%20Basemap%E2%80%9D 

 

 まず、Map の座標を設定しなければならないが、今回の対象地域がラオスであることか

ら、投影座標系である WGS 1984 UTM Zone 47N を選択する。時間があれば、全対象写真

の主点の地理座標を調べるのもよいが、ここでは時間短縮のため、16 枚のうち 2 枚のみに

ついて調べることにした9)。具体的には新しいポイントシェープファイルを作成し、写真の

主点と同じ位置を Google Satellite で探し、そこにポイントを作成した。 

写真の主点の探し方は以下の方法をとった。Photoshop で対象の写真を開き、新しいレイ

ヤーを作成する。ペンツールを使って、図 1 のように、写真の 4 辺中央部にある指標を直

線で結ぶと、写真中央部で線が交差する場所が主点となる。それと同じ地点を、ArcGIS Pro

上の Google Satellite で探す。 

 ラオスの場合、経験上、南を上向きしたほうが地形が見やすくなる。航空写真、Google 

Satellite ともそのように設定し、地形を確認しながら探すとよい。こうして 2 点のポイント

がシェープファイルに記録される。 

 次に、作成したポイントの座標を調べる。これは、ArcGIS Pro の Tools アイコンで

Toolboxes を開き、Data Management Tools>Features>Calculate Geometry Attributes で図

2 と同様の設定をし Run を押すことで、シェープファイルの属性テーブルに各ポイントの

座標値（座標系：WGS_1984_UTM_Zone_47N）を出力できる。 

 座標値の入ったデータを、Toolboxes の Conversion Tools>Excel>Table to Excel を使っ

てエクセルファイルに出力する。出力したファイルのデータを編集し、後に Metashape で

ファイルの読み込みが可能なようにする。まず写真名を正確に入力し、拡張子もつける。少

しでも間違いがあれば読み込みができなくなるので、注意する。さらに、altitude（標高）

 

9) Knuth et al. (2023: 15)は、カメラの位置について垂直座標の情報がなく、水平座標が 1

枚の写真についてしかわからない写真セットについても、Metashape などを使った一連の

オルソモザイク画像作成プロセスの中で、すべての写真のカメラ位置が適切に位置づけら

れていったことを報告している。ここで 2 枚についてしかカメラ位置座標を調べなかった

のは、この報告にヒントを得ている。 

https://socalgis.org/2020/12/02/add-google-maps-to-arcmap-and-pro/#:~:text=Once%20logged%20in%2C%20open%20a,box%20%E2%80%9CUse%20as%20Basemap%E2%80%9D
https://socalgis.org/2020/12/02/add-google-maps-to-arcmap-and-pro/#:~:text=Once%20logged%20in%2C%20open%20a,box%20%E2%80%9CUse%20as%20Basemap%E2%80%9D
https://socalgis.org/2020/12/02/add-google-maps-to-arcmap-and-pro/#:~:text=Once%20logged%20in%2C%20open%20a,box%20%E2%80%9CUse%20as%20Basemap%E2%80%9D
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のデータを入力する。これは、標定図から 22,000 フィート（6705.6 メートル）であること

がわかっているため、この値を入力する。easting, northing, altitude の値は、それぞれ小数

点の桁数をそろえる。さらに、「名前を付けて保存」から Metashape で読み込み可能な「テ

キスト（タブ区切り）（*.txt）」形式に変換して保存する。最終的なテキストファイルの内容

は、図 3 のとおりである。 

 

（３）DEM の取得 

 第 4 章第 7 節でコントロールポイントの標高を特定するために、数値標高モデル（Digital 

Elevation Model: DEM）が必要になる。DEM には DTM（Digital Terrain Model 数値地形

モデル）と DSM（Digital Surface Model 数値表層モデル）の 2 種類がある。ラオスでは、

2013 年ごろの航空写真測量に基づく DSM と DTM が作成されており、いずれも 1 セルが

12.5ｍ四方であり、精度も高いとされる10)。ラオス国立地図局で入手可能である。しかし、

価格が 1 ㎢あたり 6000kip であり、本研究のように大面積を対象とする場合はかなり高額

となってしまう。また、入手のためにはラオスに行かなければならず、あわせてラオスの研

究機関の協力がなければ普通は入手できない。 

そこで、本研究では、欧州宇宙機関（European Space Agency）が作成した DSM である

Copernicus DEM を用いることにする。これは 2011 年～2015 年に取得したデータを用い、

解像度が 10ｍ、30ｍ、90ｍの 3 種類が作成されている。このうち、10ｍのものはほぼ欧州

を対象としてしか作成されておらず、全世界を対象とするものは 30ｍと 90ｍのものである。

本研究では 30ｍのものを利用する。Copernicus DEM の精度は絶対垂直誤差（Absolute 

vertical accuracy）が 4ｍ以下、絶対水平誤差（Absolute horizontal accuracy）が 6m 以内と

される(Airbus Defence and Space GmbH 2022)。 

 現在、Copernicus DEM の 30ｍと 90ｍに関してはインターネットブラウザへの URL の入

力によって、緯度 1 度・経度 1 度単位のデータが xml フォーマットで直接ダウンロードで

きるようになっている。詳しくは、以下のホームページを参照してほしい。 

 

https://sentinels.copernicus.eu/web/sentinel/-/copernicus-dem-new-direct-data-

download-access Copernicus DEM: new direct data download access（2024 年 11 月 14 日

閲覧） 

 

 本事例の対象とする写真に関しては、南西隅が北緯 20 度東経 100 度と北緯 20 度東経 101

 

10) DEM（この場合はおそらく DSM）の高度の誤差は 2ｍ以内、平面の誤差は 1m 以内と

される。Strengthening national geographic services in Lao PDR (SNGS): Creating modern 

base map and GIS database for Lao PDR. Products and map production. 

https://proceedings.esri.com/library/userconf/proc12/papers/69_112.pdf （2023 年 11 月

14 日閲覧） 

https://sentinels.copernicus.eu/web/sentinel/-/copernicus-dem-new-direct-data-download-access
https://sentinels.copernicus.eu/web/sentinel/-/copernicus-dem-new-direct-data-download-access
https://proceedings.esri.com/library/userconf/proc12/papers/69_112.pdf
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度の隣接する二つの範囲のデータが必要となる。前者に関する Copernicus DEM をダウン

ロードするには、以下の URL をインターネットブラウザに入力すればよい。 

 

https://prism-dem-open.copernicus.eu/pd-desk-open-access/prismDownload/COP-

DEM_GLO-30-DGED__2022_1/Copernicus_DSM_10_N20_00_E100_00.tar 

 

 他のエリアの 30mDEM をダウンロードする場合は、上の URL の緯度・経度情報を変更

すればよい。 

 Windows の場合、ダウンロードした tar 形式のデータはそのままでは ArcGIS Pro で使う

ことができず、展開をする必要がある。展開の仕方については、インターネットの記事など

を参照すること。 

 展開されたフォルダの DEM というフォルダ内に、tif 形式の DEM データが入っている。

これを先ほどの ArcGIS Pro のプロジェクトに表示させる。表示させる際にラスタの統計情

報を計算するかどうか問われるが、これは Yes でよい。図 4 のように DEM が追加される。 

 2 つの DEM データは、Imagery>Raster Functions>Mosaic Rasters により 1 枚のデータ

に統合する。また、このデータは参照座標系が WGS 1984 の地理座標系なので、Map の座

標系である WGS1984 UTM47N に合わせる必要がある。これは、Analysis>Tools>Data 

Management tools>Projections and Transformations>Project Raster で行える。 

 

３．使用する航空写真の調整作業 

（１）RGB 画像への変換 

スキャンした航空写真の画像は通常、グレースケール画像となっている。このままだと、

後に作業に必要な画像の濃淡や色調を調整するためのソフトである Capture One では読み

込めないので、Photoshop を使って RGB カラー画像に変換する。「画質調整」フォルダの

うちの 1 枚を Photoshop で開き、上部メニューのイメージ＞モードで変換する。変換後、

それを保存する。今回のように処理する画像が多い場合は、「バッチ処理」の機能を使い処

理を自動化するとよい。 

 

（２）画像の色調などの調整 

Capture One を立ち上げ、左上のアイコン「インポート」を押し、出てきた「イメージの

インポート」ウィンドウの「選択」で「画像調整」フォルダ内の画像をすべて選択し、「イ

ンポートのレビュー」を押す。インポートする画像右下にチェックを入れてさらに選択する

か、下部の「すべてを選択」にチェックを入れて「import」を押す。 

 画像の調整作業は左側の「調整」タブで行う。「露出」と「ハイダイナミックレンジ」の

各パラメーターで調整する。「露出」の各パラメーターの値を大きく変えると画質が劣化す

るので注意が必要である。ただし、「明るさ」の値を下げる分には問題がない。基本的には、

「ハイダイナミックレンジ」のパラメーターおよび「露出」の「明るさ」で調整し、「露出」
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の「露出」、「コントラスト」、「彩度」については微調整にとどめる。 

 調整作業は当然、写真画像を見ながら行うが、「ヒストグラム」が目安となる。つまり、

ヒストグラムの山（ピーク/最高部）が１つとなり、それがちょうど中央あたりに位置する

ように調整するとよい（図 5 の例を参照）。写真を拡大して、画像が鮮明となっているかを

確認する。注意すべき点は、あまり暗すぎる画像にしないようにすることである。暗すぎる

と、Metashape でのアラインメントの際に画像内の特徴点を自動的に見出す作業（第 4 章

第 3 節）が困難となる。画像の四隅についても、暗くなりすぎないように注意する（「シャ

ドウ」を調整する）。 

 同じ調整内容をほかの写真に対しても適用する場合は、右上の矢印アイコンの「コピー」

をクリックする。その上で、ほかの写真を選択状態にし、「適用」をクリックすればよい。

このように、調整内容をコピー＆ペーストできることを考えると、対象地域の写真のスキャ

ンは全て同じスキャナーを用いて同じ条件でスキャンすることが望ましい。異なるスキャ

ナーを用い、異なる設定でスキャンされた写真を用いた場合、この調整作業が面倒になる。

とはいえ、写真ごとに明るさや白っぽさ、黒っぽさ、コントラストなどが微妙に違うため、

コピー＆ペーストの後も 1 枚ずつ確認し画像とヒストグラムを見ながら微調整をかける作

業はどうしても発生する。また、同じスキャナー、同じ設定でスキャンしたとしても、用い

たカメラの撮影設定（焦点距離など）や撮影された日付や時間帯により、写真自体の写り方

が異なるため、コピー＆ペーストは同一のカメラ設定、同一の日付・時間帯の写真に対して

のみすべきであることは言うまでもない。 

 全ての写真画像に対して調整作業を終えた後、画像をエクスポートする。ここで行った調

整はもとの画像（今回の事例では Tiff 画像）に上書きされるわけではなく、調整を反映し

た画像がエクスポートにより、新たに作成されることになる。つまり、それだけパソコンの

保存容量を必要とするわけで、注意が必要である。画像の一つを選択し、左上の「エクスポ

ート」アイコンをクリックする。あらかじめ、「Capture_one」などという名のフォルダを作

成しておき、「イメージをエクスポート」ウィンドウの「現像場所 フォルダ」のプルダウ

ンメニューからそのフォルダを選択する。「ネーミング」はイメージ名で良いが、フォーマ

ットとサイズには注意を要する。フォーマットについては、元の画像と同じものを踏襲し

（本事例では、Tiff 形式で色深度は 8bit。オプションは「非圧縮」とした）、プロファイル

は RGB（本事例では Adobe RGB（1998））とする。問題は解像度であるが、初めて Capture 

One を使った場合、デフォルトではこの値がかなり低くなっているため気を付ける必要が

ある。せっかく高い解像度でスキャンしたのであるから、その解像度のままでエクスポート

すべきである（本事例では 1200px/in）。スケールは固定（100%）でよい。ここを変えてし

まうと、Metashape で写真測量を行う際に問題が生じることになる。航空写真は通常、9 イ

ンチ四方（22.86 センチ四方）であり、後に Metashape で焦点距離を与える必要もあること

から、元の画像と同じ大きさにしておくべきである。「1 イメージをエクスポート」をクリ

ックすると、指定したフォルダにエクスポートされる。次に、他の画像を全て選択して「エ

クスポート」アイコンをクリックすると 1 枚目の画像と同じ設定が踏襲されているので、
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「？イメージをエクスポート」をクリックするだけでよい。 

 なお、Capture One には「保存」というオプションはない。調整中にアプリケーションを

終了しても、調整内容は自動的に保存されている。 

 

（３）画像の大きさをそろえる 

 Capture One でエクスポートした際、すべて元の画像と同じ大きさでエクスポートした

わけであるが、それらの大きさはそれぞれ微妙に異なっているものである。先ほど航空写真

は 9 インチ四方と書いたが、外枠部を含めると、その大きさはさらに 1～3cm 程度の範囲で

変わってくる。画像データについては大きさをピクセル（Pixel）で表すことが多いが、

1200dpi の航空写真の場合、1 辺が 11100pix～13000pix ほどとなる。スキャン時に同じ大

きさでスキャンするように設定していない限り、写真の大きさはピクセル単位では異なる

ことになる。 

 しかし、これをそろえておかないと、後の Photoshop を使ってマスクを設定する作業や

Metashape での Camera Calibration の作業に支障をきたすことになる。そこで、この段階

で Photoshop を使って画像の大きさをそろえておくとよい。 

 まず、処理を行う前に、各画像の大きさを確認する。Windows の場合はエクスプローラ

ーで確認できる。エクスプローラーで先ほどの Capture_one フォルダを開き、上部メニュ

ーの「表示」のドロップダウンリストからコンテンツを選択する。そうすると、各画像の大

きさ（幅、高さのピクセルサイズ）が一覧で示される。これを見て、幅、高さそれぞれの最

大値を確認しておく。それに合わせて画像の大きさを統一するのが最も効率がよい。 

 Capture One で現像後の画像の一つを、Photoshop で開く。上部メニューのイメージ＞カ

ンバスサイズで画像の周囲に黒枠を追加できる。「変更後のファイルサイズ」の「幅（W）」、

「高さ(H)」の値をそれぞれ全ての画像で同じ数値にすれば、全画像のサイズを統一できる

わけである。この際、画像をあまり大きくしすぎないようにしたい。画像を大きくした場合、

後に Metashape でコントロールポイントを追加した際に、自動的にポイントが投影される

画像が多くなってしまう（第 4 章第 7 節参照）。これは、黒枠を追加して投影できる領域を

増やしたために起こるわけであるが、その分、投影を無効化する作業がやや煩雑となる。そ

のため、最も良いのは、すべての画像の幅と高さそれぞれの最大値で大きさをそろえること

である。なお、画像の四方を切り取って大きさをそろえる方法もあるが、写真測量で重要な

示標（fiducial mark）を切り取ってしまうなどの弊害が起こる可能性があるのでお勧めしな

い。 

 この画像の大きさをそろえる作業も 1 枚目での作業を記録しておけば、他の画像に関し

てはバッチ処理で自動的に実施できる。 

 

（４）マスクの作成 

 航空写真には必ず黒い写真枠がある。この写真枠には写真番号、撮影日、撮影高度、焦点

距離などの重要情報が記載されている。しかし、Metashape でアラインメントを行い、ポイ
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ントクラウドや DEM、オルソモザイク画像を作成する作業の中では、不要な部分である。

そこで、こうした作業において枠の部分を使用しないよう設定する。これをマスク処理とい

う。 

 マスクの設定は Metashape でも行える。しかし必ずしも使い勝手はよくない。自動的に

黒枠を特定してマスク処理を施す機能も有しているが、正確にマスク処理がなされること

はまれである。そこで、ここでは Photoshop を利用してマスク処理をする方法を紹介する。 

 ここで行うのは、アルファチャネル上でマスクを設定する方法である。チャネルタブが画

面上にない場合は、ウィンドウ＞チャネルにチェックを入れる。タブの右のドロップダウン

リストから「新規チャネル」を選ぶ。「マスク範囲に色を付ける」にチェックを入れて OK

を押す。すると、RGB、レッド、グリーン、ブルーのチャネルのほかに、「アルファチャネ

ル 1」というチャネルが作成される（図 6）。次にペンツールを使って、黒枠と写真の境界部

分をなぞっていく（図 7）。事例とした 1945 年の写真については、写真の４隅が非常に暗く

なっており、この部分もオルソモザイク画像作成作業に使えそうにないのでその部分もマ

スク範囲とすることにした。ペンツールで境界部分を一周したら、チャネルタブのとなりの

パスタブを開き、「作業用パス」を右クリックして、「選択範囲を作成」を選ぶ。チャネルタ

ブに戻って、「アルファチャネル 1」を選択した状態で編集＞消去を選べば、周辺部をマス

クするアルファチャネルが出来上がる（図 8）。 

 Photoshop を使うメリットは、ペンツールを使ってのマスク作成が容易なだけでなく、そ

れをほかの画像に簡単にコピー＆ペーストできることにある。ほかの写真も境界部分や 4 隅

の暗い部分はほぼ同じであるため、一度マスクを作成したらそれを複製し他の写真に適用

するとよい。ただし注意すべきは、画像の大きさ（幅と高さ）が同じでないとコピー＆ペー

ストできないことである。この点も考慮して、前節で画像の大きさをそろえたのである。コ

ピー＆ペーストするには、マスクをコピーする画像、ペーストする画像のそれぞれを

photoshop で同時に開き、チャネルタブの「アルファチャネル 1」を選択し右クリックする。

「チャネルを複製」を選択すれば、同名のウィンドウが表れるので、「保存先」の「ドキュ

メント」でペーストする画像を選択し OK を押す。対象の画像を選択すると、確かにアルフ

ァチャネルがコピーされている。実際には写真ごとに微妙に枠の位置や 4 隅の暗がりの範

囲が違うので、鉛筆ツールや消しゴムツールを使ってマスク範囲を追加したり消去したり

する作業が必要になる。それでも、コピー＆ペーストの方が一からマスクを作成するよりも

ずっと楽なはずである。 

 なお、雲やその影、フィルム上の目立つ傷なども鉛筆ツールを使ってマスク処理するとよ

い。また、フィルムに直接書き込まれた手書きの情報などもマスクの対象とする。 

 Capture One でもマスクの自動作成機能があり、それを使うともっと早くマスク処理が

できる可能性もある。 

 

４．Metashape でのオルソモザイク画像の作成 

（１） 写真の追加 
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 ここからようやく Metashape を使ってオルソモザイク画像を作成する作業に入る。

Metashape を立ち上げると、上部のタブに Workflow というタブがある。ここからの作業は

基本的にこのタブのドロップダウンリストにある add photos, align photos, build point cloud, 

build DEM, build orthomosaic の各段階を順にたどっていくことになる。まずは add photos

を選択し、アラインメントを行う写真を追加する。ここでは、対象の 16 枚の写真を追加し

た。すると、左の Workspace ウィンドウに 16 枚の写真のリストが表示される。 

 写真を追加後にまず行いたいのは、写真の画質を確かめることである。これを確認するた

めに、まず、下部に表示されている Photos ウィンドウ（表示されていない場合は

View>Photos で表示させる）で Change View アイコンをクリックし Details 表示にする。

写真の一つを選択し、右クリックして Estimate image quality...を選択する。Analyze Images

ウィンドウで Apply to All images を選択してしばらく待つと、Quality の欄に全ての写真の

画質が表示される。説明書によると（Agisoft LLC 2023: 25）、この数値が 0.5 を切る写真は

アラインメントの結果やオルソモザイク画像の質感を損なうので使用しないほうが良いと

されている。図 9 のように、今回の写真はいずれも 0.6 台の後半となっており、「それほど

画質はよくないが使用できる」というレベルである11)。 

 次にすべきことは、マスクをインポートすることである。写真を追加しただけの状態では、

まだマスクは使用されていない。Workspace の Chunk 1 を右クリックし、Import>Import 

masks...を選ぶと、Import Masks ウィンドウが表示される。Parameters で Method を From 

Alpha、Operation を Replacement、Apply to を All images とすると、すべての写真に先ほ

ど作成したマスクが施される（Workspace の写真名をダブルクリックすれば該当の写真が

表示される）。写真が表示された状態での追加したマスクの表示/非表示の設定は上部の

Show Masks アイコンで行える。 

 ここでさらに、プロジェクトの保存を行う。File>Save...か上部の Save アイコンで行える。

適当な場所に、後でデータを開くときにも迷わずに開けるような適切な名前を付けて保存

する。 

 

（２） Camera Calibration の入力 

 アラインメントに先立って、焦点距離、主点位置、レンズ歪みなどのカメラ内部の諸要素

を入力する。Tools>Camera Calibration...でこの設定が行える（図 10）。とはいえ、本事例

において既知の要素は焦点距離のみである。主点位置については、写真の枠についている主

点示標（fiducial marks 図 11）を特定すること計算できるが、今回はこれを行わないことに

する。なぜなら、今回の対象写真については、主点示標を自動的に特定できなかったためで

ある。マニュアルで主点示標を特定する作業は、写真の枚数が多い場合は煩雑で時間がかか

ってしまい時間短縮をはかろうとする本研究の目的に反する。 

 

11) この値は、マスクのインポート後に Ignore masked image regions にチェックを入れ

て、画質を調べてもほとんど変化がなかった。 
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 同じくラオスの 1959 年、1982 年の航空写真で作業をした際は、ほぼすべての写真で自

動的に主点示標を特定することができた。これは、Camera Calibration ウィンドウで Film 

camera with fiducial marks にチェックを入れたうえで、Tools>Marks>Detect Fiducials で

示標の形式と位置を正しく設定すれば可能である。しかし、今回の 1945 年の写真に関して

は、示標の周辺が暗くなっているものが多いためか（図 11）、ほとんどの写真で正しく特定

ができていなかった。 

 また、特に複数列の写真をアラインメントする場合、示標を特定して主点位置を計算した

ことで、かえってアラインメントがうまくいかなかった事例に遭遇した。1959 年、1982 年

のいずれの写真についてもこれが起こった。逆に示標を特定しないほうがうまくいったの

である。 

 そこで、本事例では、Camera Calibration ウィンドウで入力するのは焦点距離である Focal 

length (mm)（151.6mm）のみとする。また、Focal length の値を固定せず、アラインメン

トの中でそれを調整することができるようにした。つまり、Initial タブの Fixed parameters

で Focal length(f)を指定することはしなかった。経験上、このほうがアラインメントがうま

くいくためである12)。 

 

（３） アラインメント 

 アラインメントとは、Metashape が複数の航空写真のオーバーラップ部分から多数の同

一地点（タイポイントという）を自動的に見つけ出し、その情報をもとに、焦点距離、主点

位置、レンズ歪などの内部標定要素を推定・補正するとともに、写真撮影時のカメラの位置

や傾きなどの外部標定要素を推定・補正し、カメラと写真、撮影対象の空間的位置関係を再

現する作業のことである。アラインメントができなければ、DEM やオルソモザイク画像の

作成が不可能になるわけであるが、これまでラオスの山地部での航空写真を使ったアライ

ンメントはすべて成功している。ラオスの山地が焼畑などのために活発に利用されており、

同質の森林に覆われているわけではないため、特徴点が見出しやすいことが一つの理由と

考えられる。 

 Workflow>Align Photos で出てきたウィンドウで、さまざまなパラメーターを決定する。

今回は図 12 の通り、パラメーターを設定した。Guided image matching を使用する理由は、

これが植生を写した写真や古い航空写真の高解像度スキャン画像でのアラインメント結果

をよくするのに役立つと説明書にあるためである（Agisoft LLC 2023:38）。このオプション

を使えば、1 画像あたりで探し出される特徴点（key point）の数が飛躍的に増加し、そのう

ち、複数の写真に写る点（タイポイント）も増加する。説明書によると、タイポイントの上

限は 10,000 程度が良いとされている。 

 アラインメントが成功すると、図 13 のように、カメラの撮影位置とタイポイントの位置

 

12) 本稿の作業での最終的な焦点距離の調整値は 6994.34213px であり、1200dpi では 1px

が 0.02117mm のため、148.07mm となった。3mm 以上低く調整されたことになる。 
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関係が Model ウィンドウに示される。 

 

（４） 誤差の多いタイポイントの消去 

 今回の事例では 56,453 点のタイポイントが生成されたが、多く作られた分、ノイズも多

くなっている。そこで、Model>Gradual Selection により、ここから誤差が大きいと推定さ

れる 1～2 割のポイントを消去する。 

 Gradual Selection ウィンドウで Reprojection error, Reconstruction uncertainty, Projection 

accuracy のそれぞれで Level の値を上げることで、推定誤差が大きいポイントから自動的に

選択される。それぞれのセレクションにおいて、1－2 割のポイントを選択し、OK でウィ

ンドウを閉じてから、Delete キーを押して消去する。今回の事例では、Reprojection error

で 7355 点、Reconstruction uncertainty で 7127 点、Projection accuracy で 5,542 点を削除

した。結果的にタイポイントは 36,267 点に減った。35%の減少である。今回は多めにタイ

ポイントを作成したので、セレクションもやや厳しめにした。 

 さらに、タイポイントを自身の目で確認して、タイポイントで作られた 3D モデルの上下

左右に飛び出ているタイポイントを Rectangle selection（上部のアイコン）を使って選択し、

delete キーで消去する（図 14）。この作業により 32 点減り、タイポイント数は 36,388 点と

なった。 

 

（５） 座標系の設定 

 現在の状態では、ポイントの座標系が設定されていない。座標系の設定は、Reference ウ

ィンドウの上のアイコン Settings をクリックして出てくる Reference Settings ウィンドウで

設定できる（図 15）。座標系は、xy 方向に関しては、投影座標系の WGS84/UTM zone 47N

を選択する。一方、z 方向(Vertical CS)に関しては、EGM2008 height (EPSG: 3855)を選ぶ。

この理由は本稿でコントロールポイントの標高データとして使用する Copernicus DEM が

EGM2008 ジオイドを標高の基準としているためである（Airbus Defence and Space GmbH. 

2022: 10）。こうした座標系はデフォルトでは用意されていないので、Coordinate System の

ドロップダウンリストで More...を選び、Select Coordinate System ウィンドウで投影座標系

の WGS84/UTM zone 47N を選択したのち、鉛筆マークの Edit アイコンを押して、Vertical 

CS を EGM2008 height (EPSG: 3855)として、Name を WGS84/UTM zone 47N (EGM2008)

などとして、新しい 3 次元の座標系を登録する必要がある。 

 なお、EGM2008 ジオイドモデルについては Metashape でデフォルトでは用意されてい

ないので、上の作業をする前にこのジオイドモデルを Agisoft のホームページからダウンロ

ードし、C:\Program Files\Agisoft\Metashape Pro\geoids フォルダにコピーしておく必要

がある(Agisoft LLC 2023: 200)。 

 Reference Settings ウィンドウでは Coordinate System の一番上のみ設定し、他はそのま

までよい。 
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（６） カメラの中心座標値の取り込み 

 第 2 章第 2 節で取得済みの 2 つの写真のカメラ中心座標を、Metashape に取り込む。こ

れは Reference タブの上のアイコンの左端にある Import Reference アイコンを押し、すで

に作成したテキストファイルを選択することで可能になる。図 16 の要領で、Colums の Label, 

Easting, Northing, Altitude がテキストファイルの各列の内容と合致しているかどうか注意

する。また先述したとおり、Label の列の各写真の名前にはその拡張子（この場合は.tif）を

付ける必要があり、名前は Referece ウィンドウの Cameras に表示されている名前と完全に

一致させる必要がある。 

 Accuracy には、チェックを入れる必要はない。また、Rotation に関する情報もないので、

チェックは必要ない。なお、テキストファイルの 1 行目は各列の項目名のため、ここでは

Start import at row を 2 としている。OK を押すと、Reference の Cameras 欄にこの二つの

写真に関するカメラ中心座標値がインポートされる。 

 ここで、インポートした情報をもとに、カメラアラインメントの調整をしておく。これに

より、すでにアラインされた一連の写真に対してバンドル調整がなされ、外部標定要素、内

部標定要素、三角測量により求められたタイポイントの座標値の精度を高めることができ

る（Agisoft LLC 2023: 101）。Reference ウィンドウの上部アイコンの星マークを押すと、

Optimize Camera Alignment ウィンドウが表示される（図 17）。そのまま OK を押せば、調

整がなされる。 

 

（７） コントロールポイントの追加 

 次に、タイポイントの３D モデルに現実世界の座標系を与えるために、Metashape にコ

ントロールポイントの座標値をインポートする。その前に、コントロールポイントを設定す

る必要がある。コントロールポイント作成用に、事前に Arc GIS Pro でポイントのシェープ

ファイルを作成しておく。Arc GIS Pro で Google Satellite を、Metashape で対応する範囲

が写る写真を表示させ、コントロールポイントとして適当な地点を探す。そうした地点があ

れば、Arc GIS では Edit＞Create でポイントを作成し、Metashape ではその場所で右クリ

ックをして Add Marker で Marker を追加する。後で、混同のないように、ArcGIS で作成し

たポイントには属性テーブルに ID のフィールドを作成しておき、Marker と同じ番号を打

ち込んでおくとよい。 

 今回は時間短縮を図るため、誤差は大きくてもよいので、まずはできるだけ早くオルソモ

ザイク画像を作ることを試みる。そのため、コントロールポイントは 5 点のみとした。対象

の写真はラオスの山間地域の 1945 年の画像のため、車道や橋がない。山がちの地域で水田

も少ない。それでも、大きな川とその支流が流れており、その屈曲部や合流点、川中に形成

された砂州の特徴点をコントロールポイントとすることができた（図 18）。また、山頂部に

もコントロールポイントを設定した。 

 5 点のポイントを作成した後、ArcGIS でそのポイントの座標値を取得する。基本的には

「カメラ座標値の取得」で述べたことと同じことを行うわけであるが、コントロールポイン
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トの標高は Copernicus DEM から取得する。平面の座標に関しては、Toolboxes の Data 

Management Tools>Features>Calculate Geometry Attribute を 使 っ て 、

WGS_1984_UTM_Zone_47N での座標値を取得する。さらに、標高に関しては、Spatial 

Analyst Tools>Extraction>Extract Multi Values to Points を 使 っ て 、

WGS_1984_UTM_Zone_47N に投影した Copernicus DEM から各地点の標高を取得する。

3 次元の座標値がそろったポイントシェープファイルの属性テーブルを Table to Excel でエ

クセルフォーマットで出力し、Metashape で読み込み可能な形に整え（図 19）、それをテキ

ストフォーマットとして保存しなおす。 

 一方、Metashape では、1 つの写真にコントロールポイントとして Marker を追加した場

合、その写真とオーバーラップする他の写真のほぼ同じ場所にも自動的に位置が推定され

た Marker が同じ番号で追加される。しかし、微妙にずれていることが多いため、確実に同

じ場所に Marker を移動させる作業が必要である。 

 同じ Marker を共有する写真は、Reference ウィンドウの Markers で該当する Marker を

右クリックし Filter Photos by Markers を選択すれば、Photos ウィンドウ（表示されない場

合は View>Photos で表示される）に写真が一覧で表示される。Photos ウィンドウでは、

Marker を追加した写真には緑の旗が、その他の写真には青か白の旗が付されている。まず

は Marker を追加した写真をクリックして上の画面に表示させ、次にほかの写真を右クリッ

クして Open in New Tab で新しいタブで表示させる。さらに、そうして表示されたタブを

右クリックして、Move to Other Tab Group を選択すれば、二つの写真が横並びに表示され

る（図 20）。この状態で青や白の旗の Marker を左側の緑の Marker と厳密に同じ場所に移

動させる。すると、旗の色が緑色に変化する。 

 なお、白旗 Marker の多くは Mask を設定した場所、すなわち外枠の部分に置かれている。

白旗の意味は後に Optimize Cameras で実施するバンドル調整にこの投影を反映させない

ということを意味する。Mask を設定した場所はもともと写真測量から除外している部分で

あるから、これはそのままでよい。もしも、Mask を設定した部分に青旗がたっている場合

は、それを左クリックして選択した上で右クリックして Remove Projection を選ぶ。する

と、白旗に変わる。逆に、画像の部分に白旗がたっている場合は、適切な場所に移動させて

緑旗に変える必要がある。 

 Filter Photos by Markers を選択しても Photos ウィンドウに Marker を置いた写真一枚し

か表示されないこともある。この場合も左右上下の写真を開き、同一地点がほかの写真に写

っていないかどうか確かめる必要がある。左右上下の写真に該当の Marker 名（この場合は

point 3）が付された赤線が表示されることもある（図 21）。これはこの線上のどこかに対応

点が存在する可能性を示すものである。実際、この場合は川の屈曲部の赤線付近に対応点が

あるべきであり、そこで右クリック＞Place Marker で Marker 名（この場合は point 3）を

選べば、その場所に同名の緑旗がたてられ赤線が消える。ここで、さらに Marker 名で右ク

リックして Filter Photos by Markers を選択すると、さらに多くの写真が出てくることもあ

る。これらについても、Marker 投影の調整を行う。なお、コントロールポイントとしては、
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2 枚以上の写真に写る地点を選ぶべきである。 

 Marker 投影の調整作業の終了時点では青旗がなくなり、すべてが緑旗かバンドル調整に

使用しない白旗になっている。 

 次に、コントロールポイントの 3 次元の座標値が書き込まれたテキストファイルを

Reference ウィンドウ上の Import Reference アイコンを押して選択し、インポートする。こ

の方法は、「カメラ座標値の取得」で述べたことと全く同じである。やはり、Label の列に表

示される名前と Marker の名称が完全に一致するように注意する（図 22）。Markers ウィン

ドウに各マーカーの座標値が示されていれば、インポートは完了である。 

 コントロールポイントとその 3 次元の座標値を設定し終えたところで Optimize Cameras

を押し、その情報をもとに再度バンドル調整を行う。この際注意すべきは、Markers 欄のチ

ェックボックスにチェックをすることである。そうしないとコントロールポイントとはみ

なされず（のちに述べるようにチェックポイントとみなされる）、その座標値がバンドル調

整に使用されなくなってしまう。 

 以上が完了すると、タイポイントモデルが現実世界の座標系に位置付けられる。その証拠

に、Model タブの表示で上の Show Basemap アイコンを押し Satellite を選択すれば、タイ

ポイントの点群が衛星画像上の当該地域上に示される（図 23）。 

 

（８）ポイントクラウドの作成 

 次に、より密度の高い点群であるポイントクラウドを作成する。この作業の前にすべきこ

とは、リージョンの設定である。リージョンは、この場合は点群を作成する対象範囲のこと

で、上部の Move Region, Resize Region, Rotate Region, Reset Region（この 4 つはドロップ

ダウンで変更できる）で、バウンディングボックスの位置、大きさ、角度を調整することで

設定できる。ポイントクラウドの作成時には、数点のポイントが他から大きく離れた場所に

形成されるエラーがよく起こる。リージョンを対象としたい範囲のみに絞ることで、こうし

たエラーもあらかじめ防ぐことができる。 

 Workflow>Build Point Cloud...で作成できる。今回は、図 24 のパラメーター設定とした。

まずは誤差を度外視したオルソモザイク画像を早く作ることが目的のため、ここでは

Quality は Medium とした（画像が多い場合は Low でもよい）。Calculate point colors は時

間を延ばすので、不必要な場合はチェックを入れない。数分で図 25 のような点群が形成さ

れた。 

 

（９）DEM の作成 

 ポイントクラウドをもとに、DEM（DSM）を作成する。作成は、Workflow>Build DEM...

から行い、パラメーターは図 26 のように設定した。今回の場合、処理は 30 秒程度で完了

した。 

 

（１０）オルソモザイク画像の作成 
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 次に、DEM をベースに各航空写真に対して幾何補正を行い、オルソモザイク画像を作成

する。Workflow>Build Orthomosaic を開き、図 27 のようにパラメーターを設定した。処

理は、3 分半ほどで完了した。 

 

（１１）オルソモザイク画像のエクスポート 

 作成したオルソモザイク画像は、GIS などで使用するためにエクスポートする。

File>Export>Export Orthomosaic でまず、名前を ortho などとして保存場所を指定する。

ファイル形式はいろいろと指定できるが、今回は TIFF/Geo TIFF(*.tif)とした。Export 

Orthomosaic ウィンドウでは、図 28 のような設定とした。オルソモザイク画像が 4 ギガバ

イトを超える容量になる場合は、Write BigTIFF file にチェックを入れないとエクスポート

できない点に注意が必要である。 

 

（１２）オルソモザイク画像の ArcGIS Pro への追加 

 オルソモザイク画像を、ArcGIS Pro の Map に追加する。２つの Map を表示させ、図 29

のように、一方は Google Satellite をもう一方はオルソモザイク画像を表示させるとよい。

View タブの Link Views アイコンで Center And Scale を選択すれば、左右の画像が連動す

るようになる。目的はより正確なコントロールポイントを早く、簡単に見つけ出すことにあ

る。オルソモザイク画像の位置精度は低いものの左右がほぼ同じ範囲を示すようになるた

め、コントロールポイントとすべき地点が見つけやすくなる。例えば、図 29 のような 80 年

間で形状がほとんど変わっていない山道も簡単に探し出せる。山道は道幅が 1－2m しかな

いため、その屈曲点などはかなり誤差の小さいコントロールポイントとなる。山道の屈曲点

を中心に、川や谷の屈曲部、川の岸壁、川の中の岩（図 30）、水田周辺の特徴点など比較的

誤差の少ないと考えられるコントロールポイントを 24 点探し出した。一方、当初の 5 点の

コントロールポイントは位置精度が高くないため、削除した。また、Metashape では 24 点

の Marker 投影の調整を行った。 

以上は、まずは短時間で荒い精度のオルソモザイク画像を作成し、それをもとに位置精度

の高いコントロールポイントを探すという方法である。この方法の良いところは、短時間で

比較的楽に精度の高いコントロールポイントを探せることである。今回のケースでは、24

点のコントロールポイントを ArcGIS Pro と Metashape で作成し Metashape で Marker 投

影の調整作業を行うところまでにかかった時間は、合計 5 時間程度で済んだ。 

 なお、配置するコントロールポイントについては、特定の場所に偏りすぎないよう対象範

囲の全域に均等に分布させるとともに、コンポイントが一直線に並ばないように注意しな

ければならない（Agisoft LLC 2023: 101）。 

 次に、上述したのと同じ方法で ArcGIS Pro で特定したコントロールポイントの 3 次元座

標を Metashape に取り込む。そして、Optimize Cameras アイコンを押し、再度バンドル調

整を行う。上述したように、Markers 欄のそれぞれの Marker の左のボックスにチェックを

入れなければ、それはコントロールポイントとはみなされない。チェックを入れなかった場
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合、それは誤差の計算のためのチェックポイントとみなされる。今回は 24 点のうち、20 点

をコントロールポイント、4 点をチェックポイントとすることにした。チェックポイントは、

図 31 の薄青点のように対象範囲の全域にできるだけ散らばる配置とした。 

 Optimization が終わると、各マーカーのエラーの度合いをチェックする。チェックポイ

ントのエラー値（Error (m)）は、コントロールポイントと比較すると桁違いに高いのが普

通である。ただし、チェックポイント同士、あるいはコントロールポイント同士で他のポイ

ントと比べて Error (m)の値が著しく高い場合は、ポイントの設置場所や方法に何らかの誤

りがあると考えられる。この場合には、Error (m)値が高いポイントを消去し、代わりとな

る別の場所にマーカーを設置することを検討したほうが良い。また、Error (pix)の値が高い

場合は、Marker の投影調整が十分になされておらず、写真間で厳密に同一の位置に同じ名

前の Marker を設置できていない可能性がある。 

Reference ウィンドウの View Errors を押すと、Error (m)の x, y, z 方向それぞれの値を調

べることができる。ここではあくまで 2 次元のオルソ画像作成が目的であるから、z 方向の

誤差は無視する。図 32 のように、point 14 が水平方向の誤差が他のチェックポイントと比

べ特に高いので、このポイントを削除し（Metashape の場合は名前を右クリックして

Remove Markers）、近くの別のポイントを追加して代替することにした。なお、こうした変

更を行った場合には、必ず Optimization を再度実施しなければならない。 

以上の作業プロセスを経て、結果的に、今回の事例ではチェックポイントの水平方向の

RMS 誤差の平均が 12m 程度となった。1945 年という非常に古い航空写真に関してこれほ

どの高い精度でオルソ化ができたのは、山道など誤差の少ない地点をコントロールポイン

トとすることができたためである。なお、チェックポイントの水平方向の RMS 誤差は

File>Export>Generate Report...で生成される Processing report で調べることができる。 

 

（１３）ポイントクラウドの再作成 

 新しいバンドル調整の結果をもとに、再度ポイントクラウドを作成する。今回は最終的な

結果を目的としているので、Quality は High とする。これにより、前回の Medium で作成

した時と比べ、ずっと多い点群の作成が可能である。 

 ここで注意すべきは、Advanced での Depth filtering の選択肢である。これについては説

明書（Agisoft LLC 2023）の 43 頁に記載されているので、そちらを参照していただきたい。

経験的に Mild では、ポイントクラウドの外れ値がかなり多くなり、その影響でオルソモザ

イク画像に渦巻き状の部分や穴あき部分ができてしまうことが多い。今回はポイントクラ

ウドや DEM の作成自体が目的ではないから、Aggressive でもよい。Aggressive にすると、

生成されたポイントクラウドの外れ値は、ほとんどないように見える。しかし、これをもと

に作成したオルソモザイク画像では、画像の位置精度がやや低下するように見受けられた。

そこで、今回はその中間の強度のフィルタリングである moderate を選択した。このモード

でも、渦巻き状の部分はほとんどなくなるし、穴あき部分は全く生成されなかった。また、

位置精度の低下もほとんど見られなかった。 
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 Depth Filtering に関しては、Mild, Moderate, Aggressive の順に実際にポイントクラウド

を作成し、それをもとに DEM とオルソモザイク画像を作ってみて、自分の目でどれが最も

よいかを確かめる方がよい。 

 

（１４）DEM, オルソモザイク画像の再作成 

 これらの作成に関しては、パラメーターの変更は特になく、上述した手順をそのまま実施

するのみでよい。出来上がった DEM、オルソモザイク画像をエクスポートして、ArcGIS 

Pro 上で閲覧する。図 33、図 34、図 35 がその結果であり、カラー部分が現在の Google 

Satellite、白黒部分が 1945 年の航空写真のオルソモザイク画像である。 

 

５．おわりに 

 本稿の目的は、SfM/MVS の技術を用いて、広域の航空写真から短時間で正確なオルソモ

ザイク画像を作成する手法を編み出すことにあった。本稿で明らかになったことは以下の 3

点である。 

 まず、1945 年というかなり古い航空写真からでも SfM/MVS によるオルソモザイク画像

作成が問題なくできることが示された。第 4 章第 1 節で写真の画質を調べて分かったとお

り、本稿で用いた航空写真は決して高質な画像とは言えない。しかし、それでもアラインメ

ントやポイントクラウドの作成が問題なく行えた。また、図 29 や図 30 からもよく分かる

とおり、精度の低い 5 点のコントロールポイントを与えて作成したオルソモザイク画像で

も、Google Satellite 画像と比べて大きな位置ずれはなかった。これは SfM/MVS で対応点

（タイポイント）を探し出すイメージマッチングの能力がいかに優れているかを示すもの

である。 

 第二に、今回示した方法は、精度を保ちつつ、作業量を短縮する効果が高いことが示され

た。写真測量の際に、カメラの撮影座標を調べる作業、主点示標を特定する作業はいずれも

通常であれば行うべき作業とされている。しかし、今回の結果から、こうした作業を省略、

あるいは大幅に削減してもそれなりに精度の高いオルソモザイク画像が作成できることが

示された。また、一連の作業の中でコントロールポイントとして適当な場所を探す作業は最

も手間と時間を要するものである。しかし、今回のように、まずは精度の粗いオルソモザイ

ク画像を短時間で作成しそれをもとに精度の高いコントロールポイントを探すというやり

方は、時間短縮をはかりつつ正確なオルソモザイク画像を作成するために有効な方法であ

ることが分かった。以上の時間短縮策を採れば、作業に熟練した人の場合、十数枚の写真な

ら 1～2 日でオルソモザイク画像の作成までの作業が完了するはずである。 

 第三に、1945 年のラオスの山地部の航空写真からでも、精度の高いコントロールポイン

トが取得できる場合があることが示された。本稿が対象とした地域は、1945 年時点では車

道や橋といった目立つ人工物はなかった。しかしながら、当時から人は住んでおり活発に土

地を利用しつづけてきたため、山道が 80 年間変わらず残されてきた。山道は車道よりもず

っと細いため、その屈曲点などは特に精度の高いコントロールポイントとなる。また、川の
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中の岩なども 80 年間で位置や形態が変わりにくく、小さい地物であるため、その中央や周

辺部が精度の高いコントロールポイントとして使えた。また、今回は使っていないが、ラオ

スでは水田の形が 80 年間で変わっていないことも多く、その畦畔も精度の高いコントロー

ルポイントとして使える場合がある。このように、一見コントロールポイントとして使える

場所がなさそうに見える古い写真からも、精度の良いそれが多く見つかる場合もある。その

ためには、上に示したように、まずは手早く精度の粗いオルソモザイク画像を作成して、オ

ルソ幾何補正済みの現在の航空写真や Google Satellite などと対照する方法が有効である。 
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図１ 示標を結んで写真の中心（主点）を特定する。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

図 2 Calculate Geometry Attributes の画面 
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図 3 Metashape で読み込みが可能なカメラ座標値のテキストファイル 

 

 
図 4 Copernicus DEM の ArcGIS Pro への追加 

（黄色は標定図に記載されていた写真撮影位置を示す。） 
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図 5 Capture One での画像調整作業 

 

 
図 6 Photoshop でのアルファチャネルの作成 
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図 7 ペンツールでマスクする部分の境界をなぞる。 

 

 
図 8 アルファチャネルに作成されたマスク（赤色部分） 
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図 9 写真の画質の表示 

 

 
図 10 Camera Calibration ウィンドウ 
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図 11 主点示標 (fiducial marker) 

今回使用した 16 枚の写真の中で最も示標の写りのよいものであるが、下辺のもの（左か

ら 3 つ目）は周辺が暗くなってしまっている。 

 

 
図 12 Align Photos ウィンドウでの設定 
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図 13 アラインメントされたカメラと写真とタイポイント 

 

図 14 飛び出たタイポイントを手動で消去する 
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図 15 Reference Settings ウィンドウでの設定 

 

 
図 16 カメラの三次元座標値のインポート 
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図 17 Optimize Camera Alignment ウィンドウ 

 

 
図 18 コントロールポイントの設定 
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図 19 コントロールポイントの座標値を Metashape で読み込み可能な形に整理 

 

 
図 20 他の写真（この場合は左）で投影された Marker の位置調整 
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図 21 赤線は線状（あるいはその付近）にコントロールポイントが位置する可能性を示す 

 

 
図 22 コントロールポイントの三次元座標値のインポート 
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図 23 衛星画像上に位置付けられたタイポイントモデル 

 

 
図 24 Build Point Cloud ウィンドウでの設定 
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図 25 生成されたポイントクラウド 

 

 

 
図 26 Build DEM ウィンドウでの設定 
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図 27 Build Orthomosaic ウィンドウでの設定 
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図 28 Export Orthomosaic ウィンドウでの設定 
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図 29 Google Satellite とオルソモザイク画像を見比べながら、精度の高いコントロール

ポイントを探す。 

 

 
図 30 川の中の岩が良いコントロールポイントとなる 
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図 31 コントロールポイント（赤色）とチェックポイント（薄青色）の配置 

 

 
図 32 水平方向の誤差の大きいチェックポイント、コントロールポイントの検出 

（この図では削除すべき point1～5 が残っているが、これらは除外して考える） 

 

 
図 33 上半分が Google Satellite 画像、下半分がオルソモザイク画像 
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図 34 上半分が Google Satellite 画像、下半分がオルソモザイク画像 

 

 
図 35 左側がオルソモザイク画像、右側が Google Satellite 画像 

 


